Login mot de passe
 
Menu Principal
Soutenir SQLManagerX
Certains nous ont demandés comment nous aider voici un lien pour nous soutenir


SQLManagerX
Dossiers
Accès SQLManagerX
Découvrez



SQLManagerX Pro


Qui est en ligne
15 utilisateur(s) en ligne (dont 10 sur forum)

Membre(s): 0
Invité(s): 15

plus...
Partenaires

http://www.TeeCod.fr
TeeCod


http://www.microsystem.fr
Microsystem


http://www.dag-system.fr/?lang=fr#
DAG SYSTEM


Php4WX/WM20/AlwaysData Pblm requete MySql [forum - Accès natifs]

Parcourir ce sujet :   1 Utilisateur(s) anonymes





Php4WX/WM20/AlwaysData Pblm requete MySql
Nouveau
Inscrit:
6/30 0:45
Messages: 2
Hors Ligne
Bonjour,

je voudrai vous exposé mon problème,
Voila :
j'ai héberger ma base chez alwaysdata et je travail sur une appli sous WM20, j'ai télécharger la ver 9.2.0.0 la classe est installée correctement les 02 fichiers copiés sur le serveur avec les changements suivants {
$serv = 'mysql-mysite.alwaysdata.net';
$user = 'myuser';
$pass = '';
$base = 'bdd_test';
}Connect.php

{if($_GET['test']=='OUI'){
error_reporting($e & (E_ALL -E_WARNING -E_NOTICE));
$typeBase = 'PDOMySQL';
$cmds[] = 'SELECT * from Produit';

} php4wd.php

lorsque je lance le test sur le navigateur (
http://mysite.alwaysdata.net/php4wd.php?test=oui)
MsgRetour (Fatal error: Uncaught Error: Function name must be a string in /home/mysite/www/php4wd.php:232 Stack trace: #0 {main} thrown in /home/mysite/www/php4wd.php on line 232)

la ligne 232 contient :
$session = $func_connect($serv, $user, $pass, $base) or die("<p class='Perror'>·Failed - err Connect: ".print_r($func_error())."</p>");

dans le volet programmation:
initProjet :
monAccess est un c_Php4WX

monAccess:TypeBase = "PDOMySQL"
monAccess:CryptRetour = Faux

SI PAS monAccess:mySQLConnecte("http://mysite.alwaysdata.net/php4wd.php","myuser","","bdd_test") ALORS
Erreur(monAccess:ErreurText)
FinProgramme()
SINON
estConnecte=Vrai
FIN


appuyer BTN_Test_Remplis

vrequete est une chaîne = "SELECT *FROM Produit"
Indice est un entier
Info(estConnecte)//TEST1
Info(monAccess:mySQLExec(vrequete,2))//TEST2
Trace(monAccess:mySQLLitCol(2,1))//TEST3

SI monAccess:mySQLExec(vrequete,2) ALORS
TANTQUE monAccess:mySQLFetch(2)
Indice = ZoneRépétéeAjouteLigne(ZR1)
SI Indice > 0 ALORS
ZR1[Indice].Name = monAccess:mySQLLitCol(2,1)
ZR1[Indice].prix = monAccess:mySQLLitColParNom(2,"Prix")

FIN
FIN
Erreur(monAccess:mySQLGetErrorMessage())
FIN


Résultats:
TEST1 : 1
TEST2 : 0
TEST3 : Fenêtre Vide
Bien sur aucun msg d'erreur

je n'arrive pas a trouvé où est le problème pourquoi la requête ne s'exécute pas (TEST2)

merci

Posté le : 6/30 18:08
Transférer la contribution vers d'autres applications Transférer

Sujet Auteurs Dernières réponses
     Php4WX/WM20/AlwaysData Pblm requete MySql Sani19 6/30 18:08
       Re: Php4WX/WM20/AlwaysData Pblm requete MySql Firetox 6/30 18:23
         Re: Php4WX/WM20/AlwaysData Pblm requete MySql Sani19 6/30 22:18





[Recherche avancée]


Copyright: © 2004 By SQLManagerX
WinDev©, WebDev© et HyperFile© sont des marques déposées par PCSoft.
By Firetox
IMAGO:THEMES Theme Design by IMAGO DESIGN CORP.